Nie można wyświetlić tego widżeta.
Nie można wyświetlić tego widżeta.
Nie można wyświetlić tego widżeta.

LiveBox 2.0 Duże problemy z otwieraniem portów i w ogóle dowodzeniem na 192.168.1.1

ROZWIĄZANE

Poziom 13, Tropiciel Przestworzy
  • 15
  • 16
  • 0

LiveBox 2.0 Duże problemy z otwieraniem portów i w ogóle dowodzeniem na 192.168.1.1

Próbowałem na Opera GX, Microsoft Edge, Google Chrome, Firefox
ciągle nic 


Poziom 37, Nawigator Galaktyczny
  • 5580
  • 22636
  • 186

LiveBox 2.0 Duże problemy z otwieraniem portów i w ogóle dowodzeniem na 192.168.1.1

@Danioxxxxx 

A kwestia protokołu? Czysty, nieszyfrowany HTTP? Przez wpisanie w adresie wprost:

http://192.168.1.1

 


Poziom 13, Tropiciel Przestworzy
  • 15
  • 16
  • 0

LiveBox 2.0 Duże problemy z otwieraniem portów i w ogóle dowodzeniem na 192.168.1.1

Również to samo 


Poziom 37, Nawigator Galaktyczny
  • 5580
  • 22636
  • 186

LiveBox 2.0 Duże problemy z otwieraniem portów i w ogóle dowodzeniem na 192.168.1.1

@Danioxxxxx 

No to faktycznie dziwne. U mnie podobny (ale nieidentyczny) efekt na FB daje się wywołać na FF przy aktywnej wtyczce NoScript. Pewnie niewiele Ci to pomoże, ale może na coś naprowadzi.

 

Kiedy próbujesz klikać w pole "urządzenie" na problematycznym ekranie (tym od konfiguracji NAT/PAT), to nic się nie dzieje? Czy też otwiera się jakieś menu?

 

W sumie najważniejsze pytanie jest zupełnie inne. Czy próbujesz skonfigurować coś kompletnie nowego, czego jeszcze nie robiłeś na tym ruterze, czy też miałeś to już skonfigurowane, działało i przestało działać? Warto walczyć z konfiguracją tylko jeśli to nowa konfiguracja, jeśli działało i przestało to nie ma co tracić czasu tylko trzeba zgłosić awarię. Ten ruter to już sprzęt archaiczny, podejrzewam że wymiana na nieco nowszy FunBox 2 będzie możliwa bez problemu.

 


Poziom 19, Odkrywca Przestworzy
  • 85
  • 186
  • 1

LiveBox 2.0 Duże problemy z otwieraniem portów i w ogóle dowodzeniem na 192.168.1.1

@Danioxxxxx 

Jeszcze sprawdź to, co na poniższym screenie. Też wszystko powinno zakończyć się dwusetkami. 

ajax.png

 


Poziom 13, Tropiciel Przestworzy
  • 15
  • 16
  • 0

LiveBox 2.0 Duże problemy z otwieraniem portów i w ogóle dowodzeniem na 192.168.1.1

Jak klikam w pole "urządzenie" nic się nie otwiera, również nic nie mogę napisać 
Próbuje to skonfigurować pierwszy raz

Danioxxxxx_1-1635546081766.png

 

A to jak mam wtyczkę NoScript coś tam się odblokowywuję ale no ciężko coś zrobić 

 

Danioxxxxx_0-1635546175969.png

 

 

 

 

___________________

*Połączenie dwóch postów w jeden - moderator Wojciech


Poziom 19, Odkrywca Przestworzy
  • 85
  • 186
  • 1

LiveBox 2.0 Duże problemy z otwieraniem portów i w ogóle dowodzeniem na 192.168.1.1

W prawym górnym rogu w dev tools widać czerwone kółko, jest jakiś błąd krytyczny. Patrzyłeś jaki? 

Być może to jakiś błąd javascriptu, który uniemożliwia poprawne wyświetlanie. 

Druga sprawa, sprawdź w Response dla Devices:get czy są jakieś urządzenia.


Poziom 37, Nawigator Galaktyczny
  • 5580
  • 22636
  • 186

LiveBox 2.0 Duże problemy z otwieraniem portów i w ogóle dowodzeniem na 192.168.1.1

@Danioxxxxx 

Noscript musi być wyłączona dla adresu 192.168.1.1. Ta strona musi być ustawiona jako "trusted". Brak reakcji na kliknięcia potwierdza że problem jest w przeglądarce. Nie znaczy że nie ma innych problemów, ale w przeglądarce na 100% coś blokuje skrypty konfiguracyjne. Narzędzia które proponuje @egzorcysta powinny Ci pokazać co konkretnie jest blokowane. Bez usunięcia tego problemu dalej się nie przejdzie.


Poziom 13, Tropiciel Przestworzy
  • 15
  • 16
  • 0

LiveBox 2.0 Duże problemy z otwieraniem portów i w ogóle dowodzeniem na 192.168.1.1

Danioxxxxx_0-1635585864266.png
nie wiem czy o to chodzi ale to pisze w response 

Pokaż szczegóły
{
"result": {
"status": [
{
"physAddress": "bc:5f:f4:e2:e4:d6",
"ipAddress": "192.168.1.10",
"addressSource": "DHCP",
"detectedTypes": "Computer",
"leaseTimeRemaining": -1,
"vendorClassID": "MSFT 5.0",
"clientID": "01:bc:5f:f4:e2:e4:d6",
"userClassID": "",
"hostName": "DESKTOP-LV3FBMM",
"dnsName": "pc1",
"uPnPNames": "",
"mDNSNames": "",
"lLTDDevice": false,
"sSID": "",
"active": true,
"lastConnection": "2021-10-30T11:31:42Z",
"tags": "ipv4",
"layer2Interface": "eth0",
"interfaceType": "Ethernet",
"manufacturerOUI": "000000",
"serialNumber": "",
"productClass": "",
"deviceIcon": "",
"deviceLocation": "",
"deviceType": "Computer",
"addresses": [
{
"ipAddress": "192.168.1.10",
"addressSource": "DHCP",
"state": "permanent",
"scope": "global",
"routable": true,
"family": "IPv4"
}
],
"names": [
{
"name": "PC1",
"source": "default"
},
{
"name": "DESKTOP-LV3FBMM",
"source": "DHCP"
}
],
"icons": []
},
{
"physAddress": "4c:02:20:41:5b:45",
"ipAddress": "192.168.1.16",
"addressSource": "DHCP",
"detectedTypes": "",
"leaseTimeRemaining": -1,
"vendorClassID": "android-dhcp-10",
"clientID": "01:4c:02:20:41:5b:45",
"userClassID": "",
"hostName": "Android-3",
"dnsName": "pc2",
"uPnPNames": "",
"mDNSNames": "Android-3",
"lLTDDevice": false,
"sSID": "",
"active": true,
"lastConnection": "2021-10-30T11:31:42Z",
"tags": "ipv4",
"layer2Interface": "wl0",
"interfaceType": "802.11",
"manufacturerOUI": "000000",
"serialNumber": "",
"productClass": "",
"deviceIcon": "",
"deviceLocation": "",
"deviceType": "Computer",
"addresses": [
{
"ipAddress": "192.168.1.16",
"addressSource": "DHCP",
"state": "permanent",
"scope": "global",
"routable": true,
"family": "IPv4"
}
],
"names": [
{
"name": "PC2",
"source": "default"
},
{
"name": "Android-3",
"source": "mDNS"
},
{
"name": "RedmiNote9Pro-RedmiN",
"source": "DHCP"
}
],
"icons": []
},
{
"physAddress": "08:00:27:43:73:bc",
"ipAddress": "192.168.1.19",
"addressSource": "DHCP",
"detectedTypes": "",
"leaseTimeRemaining": -1,
"vendorClassID": "",
"clientID": "01:08:00:27:43:73:bc",
"userClassID": "",
"hostName": "kali",
"dnsName": "pc3",
"uPnPNames": "",
"mDNSNames": "",
"lLTDDevice": false,
"sSID": "",
"active": false,
"lastConnection": "2021-10-29T20:51:22Z",
"tags": "ipv6 ipv4",
"layer2Interface": "eth0",
"interfaceType": "Ethernet",
"manufacturerOUI": "000000",
"serialNumber": "",
"productClass": "",
"deviceIcon": "",
"deviceLocation": "",
"deviceType": "Computer",
"addresses": [
{
"ipAddress": "192.168.1.19",
"addressSource": "DHCP",
"state": "permanent",
"scope": "global",
"routable": true,
"family": "IPv4"
}
],
"names": [
{
"name": "PC3",
"source": "default"
},
{
"name": "kali",
"source": "DHCP"
}
],
"icons": []
},
{
"physAddress": "10:2c:6b:95:9d:d4",
"ipAddress": "192.168.1.11",
"addressSource": "DHCP",
"detectedTypes": "",
"leaseTimeRemaining": -1,
"vendorClassID": "��X���g|�o������{k��Qd��TCa�;P\fWS]I�Ք��",
"clientID": "01:10:2c:6b:95:9d:d4",
"userClassID": "",
"hostName": "0f4a2c1a-f325-e870-2193-1f1ab507de10",
"dnsName": "pc4",
"uPnPNames": "",
"mDNSNames": "Android-3;0f4a2c1a-f325-e870-2193-1f1ab507de10;Android-2;Android",
"lLTDDevice": false,
"sSID": "",
"active": true,
"lastConnection": "2021-10-30T11:31:42Z",
"tags": "ipv6 ipv4",
"layer2Interface": "wl0",
"interfaceType": "802.11",
"manufacturerOUI": "000000",
"serialNumber": "",
"productClass": "",
"deviceIcon": "",
"deviceLocation": "",
"deviceType": "Computer",
"addresses": [
{
"ipAddress": "192.168.1.11",
"addressSource": "DHCP",
"state": "permanent",
"scope": "global",
"routable": true,
"family": "IPv4"
},
{
"ipAddress": "fe80:0000:0000:0000:122c:6bff:fe95:9dd4",
"addressSource": "Static",
"state": "stale",
"scope": "link",
"routable": false,
"family": "IPv6"
},
{
"ipAddress": "2a01:111f:0814:8b00:49f8:a78f:d067:4a2b",
"addressSource": "Static",
"state": "stale",
"scope": "link",
"routable": true,
"family": "IPv6"
}
],
"names": [
{
"name": "PC4",
"source": "default"
},
{
"name": "0f4a2c1a-f325-e870-2193-1f1ab507de10",
"source": "mDNS"
}
],
"icons": []
},
{
"physAddress": "04:02:1f:bb:1f:23",
"ipAddress": "192.168.1.14",
"addressSource": "DHCP",
"detectedTypes": "",
"leaseTimeRemaining": -1,
"vendorClassID": "dhcpcd-5.5.6",
"clientID": "01:04:02:1f:bb:1f:23",
"userClassID": "",
"hostName": "android-bc32fb670743f99c",
"dnsName": "pc5",
"uPnPNames": "",
"mDNSNames": "",
"lLTDDevice": false,
"sSID": "",
"active": false,
"lastConnection": "2021-10-30T04:42:15Z",
"tags": "ipv6 ipv4",
"layer2Interface": "wl0",
"interfaceType": "802.11",
"manufacturerOUI": "000000",
"serialNumber": "",
"productClass": "",
"deviceIcon": "",
"deviceLocation": "",
"deviceType": "Computer",
"addresses": [
{
"ipAddress": "192.168.1.14",
"addressSource": "DHCP",
"state": "permanent",
"scope": "global",
"routable": true,
"family": "IPv4"
}
],
"names": [
{
"name": "PC5",
"source": "default"
},
{
"name": "android-bc32fb670743f99c",
"source": "DHCP"
}
],
"icons": []
},
{
"physAddress": "f4:30:8b:40:64:7e",
"ipAddress": "192.168.1.13",
"addressSource": "DHCP",
"detectedTypes": "",
"leaseTimeRemaining": -1,
"vendorClassID": "android-dhcp-10",
"clientID": "01:f4:30:8b:40:64:7e",
"userClassID": "",
"hostName": "M2006C3LG-eyjebieciw",
"dnsName": "pc6",
"uPnPNames": "",
"mDNSNames": "",
"lLTDDevice": false,
"sSID": "",
"active": false,
"lastConnection": "2021-10-30T11:27:07Z",
"tags": "ipv4",
"layer2Interface": "wl0",
"interfaceType": "802.11",
"manufacturerOUI": "000000",
"serialNumber": "",
"productClass": "",
"deviceIcon": "",
"deviceLocation": "",
"deviceType": "Computer",
"addresses": [
{
"ipAddress": "192.168.1.13",
"addressSource": "DHCP",
"state": "permanent",
"scope": "global",
"routable": true,
"family": "IPv4"
}
],
"names": [
{
"name": "PC6",
"source": "default"
},
{
"name": "M2006C3LG-eyjebieciw",
"source": "DHCP"
}
],
"icons": []
},
{
"physAddress": "b8:08:d7:3a:d3:ac",
"ipAddress": "",
"addressSource": "None",
"detectedTypes": "",
"leaseTimeRemaining": 0,
"vendorClassID": "",
"clientID": "",
"userClassID": "",
"hostName": "PC7",
"dnsName": "pc7",
"uPnPNames": "",
"mDNSNames": "",
"lLTDDevice": false,
"sSID": "",
"active": false,
"lastConnection": "2021-10-29T19:19:17Z",
"tags": "",
"layer2Interface": "wl0",
"interfaceType": "802.11",
"manufacturerOUI": "000000",
"serialNumber": "",
"productClass": "",
"deviceIcon": "",
"deviceLocation": "",
"deviceType": "Computer",
"addresses": [],
"names": [
{
"name": "PC7",
"source": "default"
}
],
"icons": []
},
{
"physAddress": "88:36:5f:fe:93:c8",
"ipAddress": "192.168.1.15",
"addressSource": "DHCP",
"detectedTypes": "",
"leaseTimeRemaining": -1,
"vendorClassID": "android-dhcp-7.0",
"clientID": "01:88:36:5f:fe:93:c8",
"userClassID": "",
"hostName": "android-800aec83fdf4c12f",
"dnsName": "pc8",
"uPnPNames": "",
"mDNSNames": "",
"lLTDDevice": false,
"sSID": "",
"active": false,
"lastConnection": "2021-10-30T11:27:07Z",
"tags": "ipv4",
"layer2Interface": "wl0",
"interfaceType": "802.11",
"manufacturerOUI": "000000",
"serialNumber": "",
"productClass": "",
"deviceIcon": "",
"deviceLocation": "",
"deviceType": "Computer",
"addresses": [
{
"ipAddress": "192.168.1.15",
"addressSource": "DHCP",
"state": "permanent",
"scope": "global",
"routable": true,
"family": "IPv4"
}
],
"names": [
{
"name": "PC8",
"source": "default"
},
{
"name": "android-800aec83fdf4c12f",
"source": "DHCP"
}
],
"icons": []
}
]
}
}

 


Poziom 19, Odkrywca Przestworzy
  • 85
  • 186
  • 1

LiveBox 2.0 Duże problemy z otwieraniem portów i w ogóle dowodzeniem na 192.168.1.1

@Danioxxxxx 

Masz jakieś urządzenie o adresie MAC 10:2c:6b:95:9d:d4, jest to firma AMPAK Technology, Inc.

Jest podłączone przez WiFi. 

Sytuacja wygląda tak:

Po restarcie routera do ustawień fabrycznych problem znika i jakiś czas działa, jak sam wspomniałeś.

Potem podłącza się to urządzenie od AMPAK. Wysyła zapytanie o DHCP do routera z Opcją 60 (Vendor ID), której wartość jest nieprawidłowa (to są te krzaczki w tym co wkleiłeś). W tym momencie oprogramowanie liveboxa się wykłada, ponieważ powinno sobie z tym poradzić (odrzucić), ale niestety zapisuje tą niepoprawną wartość. Znów niestety, nawet jak je odłączysz, to w pamięci Liveboxa jest ciągle zapisane. Znów niestety, oprogramowanie liveboxa jest tak dziwnie skonstruowane, że frontend wysyła zapytanie o wszystkie urządzenia, nawet te niepodłączone i livebox je wraca w niepoprawnym JSONIE. Ponieważ JSON jest niepoprawny, forntend go nie parsuje i się wywala i nic nie działa.

 

Jeżeli chcesz się pobawić, możesz za pomocą Wiresharka podpatrzeć co się dzieje, ale pewnie cię to nie interesuje więc zrób tak:

1) dowiedz się co to za urzązenie, które ma adres IP 192.168.1.11

2) wyłącz to urządzenie

3) zresetuj router i zobacz czy działa NAT/PAT

4) podłącz to urządzenie. 

Jeżeli teraz NAT/PAT nie działa to bingo, mamy winnego. Wtedy wystarczy wyłączyć tam DHCP i ustawić tam statyczne IP.