Nie można wyświetlić tego widżeta.
Nie można wyświetlić tego widżeta.
Nie można wyświetlić tego widżeta.

Smart WI-FI BOX i problem z VPN

ROZWIĄZANE

Poziom 13, Tropiciel Przestworzy
  • 7
  • 25
  • 0

Smart WI-FI BOX i problem z VPN

Mam dokładnie to samo, nie było kłopotu jak używałem - do wczoraj - SMB starego, wymieniłem go na SMB6 i jest kicha. VPN łączy się gładko, po czym nie działa nic (traceroute wp.pl * * * ...), VPN się rozłącza sam po ~3 minutach. Routing, DNS - wysztko to samo jak uruchamiam VPNa przy FB a jednak tam nie ma takich objawów. 

Zmieniałem ustawienia VPNa i nic. A co dziwne mojej żonie działa, ona używa innego VPNa i Windowsa ale jest ok.

Ktoś coś na to wymyślił może ?

 

tomki99 


Poziom 15, Badacz Przestworzy
  • 9
  • 16
  • 1

Smart WI-FI BOX i problem z VPN

Powiem tak. Temat jest na pewno związany z komunikacją, konfiguracją, czymkolwiek zależnym od Smart WI-FI BOX czy też przejściem danych przez Smart WI-FI BOX bo tak jak zauważyliśmy kiedy nie używa się "przeskoku" przez SWB to problemu z VPN nie ma. Niestety nie udało mi się dojść co dokładnie powoduje problem. Nie testowałem też VPNa na jakimś innym repeaterze firm trzecich więc nie wiem czy to wina konkretnie SWB czy ogólnie tego, że w ścieżce danych jest wzmacniacz.

U mnie temat udało się jednak naprawić po stronie administratorów w firmie i za pomocą konfiguracji VPNa.  Coś tam zmienili i teraz normalnie mogę się łączyć przez wzmacniacz z użyciem VPN nawet z kilku laptopów na raz. Niestety nie wiem co dokładnie tam zrobili. Spróbuję popytać, może się czegoś dowiem to dam znać.


Poziom 41, Sternik Międzygalaktyczny
  • 13519
  • 55276
  • 661

Smart WI-FI BOX i problem z VPN

@Dompaw13  o ilezrozumialem, to ustawienia VPN odniosły skutek? Idąc tym tropem nawet jak następują zmiany związane z komunikacją pomiędzy modemem a SWB,  to można je obejść konfiguracja ustawień połączenia VPN 

Czyli wina lub rozwiązanie nie leży tylko po stronie sprzętu operatora???

Warto to wyjaśnić do końca i opisać dokładnie, bo problem wygląda inaczej, a jest innego typu i ma rozwiązanie 


Poziom 13, Tropiciel Przestworzy
  • 7
  • 25
  • 0

Smart WI-FI BOX i problem z VPN

w sumie nie wiem dlaczego to zadziałało ale udało się - teraz już mi działa. Używam Ubuntu i zatrzymałem demona xl2tpd (layer 2 tunelling protocol daemon). Po zatrzymaniu go komendą 

sysctl stop xl2tpd

VPN się zestawia (przy połączeniu przez SMB) i połączenie jest - tak do publicznych stron jak i firmowych, a do tego nie zrywa połączenia.

może komuś się przyda 🙂


Poziom 37, Nawigator Galaktyczny
  • 5730
  • 23251
  • 197

Smart WI-FI BOX i problem z VPN


@tomki99napisał(-a)

w sumie nie wiem dlaczego to zadziałało ale udało się - teraz już mi działa. Używam Ubuntu i zatrzymałem demona xl2tpd (layer 2 tunelling protocol daemon). Po zatrzymaniu go komendą 

sysctl stop xl2tpd

VPN się zestawia (przy połączeniu przez SMB) i połączenie jest - tak do publicznych stron jak i firmowych, a do tego nie zrywa połączenia.

może komuś się przyda 🙂


Super. Ale żeby się to komuś przydało byłoby fajnie gdybyś podał nieco kontekstu. Skąd jest to połączenie VPN nawiązywane i jaka jest minimalna konfiguracja sieci przy której to działa.

Generalnie mnie to nie dziwi, FB3 raczej z zestawianiem tych tuneli nie interferuje więc jeśli tylko na obu końcach konfiguracja jest ogarnięta to musi działać (no w każdym razie u mnie działa przez klienta FortiSSL bez otwierania czegokolwiek na FB3, przez podwójny NAT z podsieci - przez 12 miesięcy jeszcze ani razu nie zerwało połączenia). IMHO czasem zgłaszane problemy z VPN na usłudze FTTH wynikają wyłącznie z błędnej konfiguracji terminala i jedynie IT po drugiej stronie tunelu może pomóc. Ale podkreślam jeszcze raz że to tylko IMHO.


Poziom 13, Tropiciel Przestworzy
  • 7
  • 25
  • 0

Smart WI-FI BOX i problem z VPN

Więcej kontekstu:

- VPN to l2tp (a konkretnie network-manager-l2tp)

- FB6 + SMB6 (zewnętrzne ONT)

- VPN na FB6 wszystko śmiga

- VPN na SMB6 bez powyższej komendy - wyszstko się zatrzymywało, ping, traceroute, zero dostępu

- SMB6 w trybie punktu dostępowego - konfiguracja automatycznie zassana z FB6 - nie działał

- SMB6 po reset fabryczny z swoją siecią i domyślnym hasłem  - VPN nie działał

- SMB6 po kablu - VPN działał

... taka sytuacja. Niby rozumiem wiele ale i tak nie wiem jaki jest root cause.

szczegóły VPNa:

tomki99_0-1655876124121.pngtomki99_1-1655876149044.png